Overview
After sending a video through GoVideo, you can expect to receive a notification that the recipient has watched a video. This will appear in the Feed tab when clicking on the V-buddy icon, as well as other indicators in the browser such as a digit on the icon itself.
Symptom
You have sent one or many GoVideo recordings, but have not received notification that the videos have been watched.
Cause
This is likely due to one of the following:
- The emails/links were not sent out correctly.
- The emails have gone into a junk box and have gone unnoticed.
- The emails simply haven't been seen yet. Are your recipient(s) in a different time zone?
- The emails were deleted without being opened.
- The emails were opened, but the video was not clicked on.
Solution
If you have a way to monitor the status of emails, then this will provide insight into whether the recipient received the message. It may be difficult to know if it went into their junk box without asking them directly.
If you believe the emails have been sent correctly but were deleted without the videos being watched, consider your email subject line or the splashscreen the video splashscreen and review how they might be made more engaging. Visit out website to learn about GoVideo best practices and ways to improve engagement.